vazco/uniforms v3.0.0-rc.0 Release Notes

Release Date: 2020-07-15 // almost 2 years ago
    • ๐Ÿ’ฅ Breaking: Minimum antd version for uniforms-antd is 4.0.0. #696
    • ๐Ÿ’ฅ Breaking: Minimum @material-ui/core version for uniforms-material is 4.0.0. #758
    • โž• Added: New FieldProps and HTMLFieldProps utility types. #760
    • โž• Added: Improved typing of filterDOMProps. To properly register a new property, extend FilterDOMProps interface. #763
      declare module 'uniforms' {
        interface FilterDOMProps {
          customPropToFilter: never;
        }
      }
    
      filterDOMProps.register('customPropToFilter');
    
    • ๐Ÿ›  Fixed: Escaping special characters. #753
    • ๐Ÿ›  Fixed: Changed state of AutoForm regression. #765